Pidgin: Multiple vulnerabilities — GLSA 201405-22

Multiple vulnerabilities in Pidgin may allow execution of arbitrary code.

Affected Packages

net-im/pidgin on all architectures
Affected versions < 2.10.9
Unaffected versions >= 2.10.9, revision >= 2.10.9-r1

Background

Pidgin is a GTK Instant Messenger client for a variety of instant messaging protocols.

Description

Multiple vulnerabilities have been discovered in Pidgin. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the Pidgin process, cause a Denial of Service condition, overwrite files, or spoof traffic.

Workaround

There is no known workaround at this time.

Resolution

All Pidgin users on HPPA or users of GNOME 3.8 and later on AMD64 or X86 should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-im/pidgin-2.10.9-r1"
 

All Pidgin users on ALPHA, PPC, PPC64, SPARC, and users of GNOME before 3.8 on AMD64 and X86 should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-im/pidgin-2.10.9"
 

References

Release Date
May 18, 2014

Latest Revision
May 18, 2014: 1

Severity
high

Exploitable
remote

Bugzilla entries