rxvt-unicode: User-assisted execution of arbitrary code — GLSA 201406-18

A vulnerability in rxvt-unicode may allow a remote attacker to execute arbitrary code.

Affected Packages

x11-terms/rxvt-unicode on all architectures
Affected versions < 9.20
Unaffected versions >= 9.20

Background

rxvt-unicode (urxvt) is a clone of the rxvt terminal emulator.

Description

rxvt-unicode does not properly handle OSC escape sequences, including those used to read and write X window properties.

Impact

A remote attacker could entice a user to run a specially crafted file using rxvt-unicode, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All rxvt-unicode users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=x11-terms/rxvt-unicode-9.20"
 

References

Release Date
June 19, 2014

Latest Revision
June 19, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries