Konqueror: Multiple vulnerabilities — GLSA 201406-31

Multiple vulnerabilities have been found in Konqueror, the worst of which may allow execution of arbitrary code.

Affected Packages

kde-base/konqueror on all architectures
Affected versions < 4.9.3-r1
Unaffected versions >= 4.9.3-r1

Background

Konqueror is the KDE web browser and file manager.

Description

Multiple vulnerabilities have been discovered in Konqueror. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could entice a user to open a specially crafted web site using Konqueror, possibly resulting in the execution of arbitrary code with the privileges of the process or a Denial of Service condition

Workaround

There is no known workaround at this time.

Resolution

All Konqueror users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=kde-base/konqueror-4.9.3-r1"
 

NOTE: This is a legacy GLSA. Updates for all affected architectures are available since November 11, 2012. It is likely that your system is already no longer affected by this issue.

References

Release Date
June 27, 2014

Latest Revision
June 27, 2014: 1

Severity
normal

Exploitable
remote

Bugzilla entries