Xen: Multiple Vunlerabilities — GLSA 201407-03

Multiple vulnerabilities have been found in Xen, the worst of which could lead to arbitrary code execution.

Affected Packages

app-emulations/xen on all architectures
Affected versions < 4.3.2-r4
Unaffected versions >= 4.3.2-r4, revision >= 4.2.4-r4
app-emulations/xen-tools on all architectures
Affected versions < 4.3.2-r5
Unaffected versions >= 4.3.2-r5, revision >= 4.2.4-r6
app-emulations/xen-pvgrub on all architectures
Affected versions < 4.3.2
Unaffected versions revision >= 4.3.2, revision >= 4.2.4

Background

Xen is a bare-metal hypervisor.

Description

Multiple vulnerabilities have been discovered in Xen. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker can utilize multiple vectors to execute arbitrary code, cause Denial of Service, or gain access to data on the host.

Workaround

There is no known workaround at this time.

Resolution

All Xen 4.3 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulations/xen-4.3.2-r2"
 

All Xen 4.2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulations/xen-4.2.4-r2"
 

All xen-tools 4.3 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=app-emulations/xen-tools-4.3.2-r2"
 

All xen-tools 4.2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=app-emulations/xen-tools-4.2.4-r2"
 

All Xen PVGRUB 4.3 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulations/xen-pvgrub-4.3.2"
 

All Xen PVGRUB 4.2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulations/xen-pvgrub-4.2.4"
 

References

Release Date
July 16, 2014

Latest Revision
July 16, 2014: 1

Severity
high

Exploitable
remote

Bugzilla entries