Linux kernel do_mremap() local privilege escalation vulnerability — GLSA 200401-01

A critical security vulnerability has been found in recent Linux kernels which allows for local privelege escalation.

Affected Packages

sys-kernel/aa-sources on all architectures
Affected versions < 2.4.23-r1
Unaffected versions >= 2.4.23-r1
sys-kernel/alpha-sources on all architectures
Affected versions < 2.4.21-r2
Unaffected versions >= 2.4.21-r2
sys-kernel/arm-sources on all architectures
Affected versions < 2.4.19-r2
Unaffected versions >= 2.4.19-r2
sys-kernel/ck-sources on all architectures
Affected versions < 2.4.23-r1
Unaffected versions >= 2.4.23-r1
sys-kernel/compaq-sources on all architectures
Affected versions < 2.4.9.32.7-r1
Unaffected versions >= 2.4.9.32.7-r1
sys-kernel/development-sources on all architectures
Affected versions < 2.6.1_rc3
Unaffected versions >= 2.6.1_rc3
sys-kernel/gaming-sources on all architectures
Affected versions < 2.4.20-r7
Unaffected versions >= 2.4.20-r7
sys-kernel/gentoo-dev-sources on all architectures
Affected versions < 2.6.1_rc3
Unaffected versions >= 2.6.1_rc3
sys-kernel/gentoo-sources on all architectures
Affected versions < 2.4.22-r3
Unaffected versions > 2.4.22-r3
sys-kernel/grsec-sources on all architectures
Affected versions < 2.4.23.2.0_rc4-r1
Unaffected versions > 2.4.23.2.0_rc4-r1
sys-kernel/gs-sources on all architectures
Affected versions < 2.4.23_pre8-r2
Unaffected versions >= 2.4.23_pre8-r2
sys-kernel/hardened-sources on all architectures
Affected versions < 2.4.22-r2
Unaffected versions >= 2.4.22-r2
sys-kernel/hppa-sources on all architectures
Affected versions < 2.4.23_p4-r2
Unaffected versions >= 2.4.23_p4-r2
sys-kernel/ia64-sources on all architectures
Affected versions < 2.4.22-r2
Unaffected versions >= 2.4.22-r2
sys-kernel/mips-prepatch-sources on all architectures
Affected versions < 2.4.24_pre2-r1
Unaffected versions >= 2.4.24_pre2-r1
sys-kernel/mips-sources on all architectures
Affected versions < 2.4.23-r2
Unaffected versions >= 2.4.23-r2
sys-kernel/mm-sources on all architectures
Affected versions < 2.6.1_rc1-r2
Unaffected versions >= 2.6.1_rc1-r2
sys-kernel/openmosix-sources on all architectures
Affected versions < 2.4.22-r3
Unaffected versions >= 2.4.22-r3
sys-kernel/pac-sources on all architectures
Affected versions < 2.4.23-r1
Unaffected versions >= 2.4.23-r1
sys-kernel/pfeifer-sources on all architectures
Affected versions < 2.4.21.1_pre4-r1
Unaffected versions >= 2.4.21.1_pre4-r1
sys-kernel/planet-ccrma-sources on all architectures
Affected versions < 2.4.21-r4
Unaffected versions >= 2.4.21-r4
sys-kernel/ppc-development-sources on all architectures
Affected versions < 2.6.1_rc1-r1
Unaffected versions >= 2.6.1_rc1-r1
sys-kernel/ppc-sources on all architectures
Affected versions < 2.4.23-r1
Unaffected versions >= 2.4.23-r1
sys-kernel/ppc-sources-benh on all architectures
Affected versions < 2.4.22-r4
Unaffected versions >= 2.4.22-r4
sys-kernel/ppc-sources-crypto on all architectures
Affected versions < 2.4.20-r2
Unaffected versions >= 2.4.20-r2
sys-kernel/selinux-sources on all architectures
Affected versions < 2.4.24
Unaffected versions >= 2.4.24
sys-kernel/sparc-dev-sources on all architectures
Affected versions < 2.6.1_rc2
Unaffected versions >= 2.6.1_rc2
sys-kernel/sparc-sources on all architectures
Affected versions < 2.4.24
Unaffected versions >= 2.4.24
sys-kernel/usermode-sources on all architectures
Affected versions < 2.4.23-r1
Unaffected versions >= 2.4.23-r1
sys-kernel/vanilla-prepatch-sources on all architectures
Affected versions < 2.4.25_pre4
Unaffected versions >= 2.4.25_pre4
sys-kernel/vanilla-sources on all architectures
Affected versions < 2.4.24
Unaffected versions >= 2.4.24
sys-kernel/win4lin-sources on all architectures
Affected versions < 2.6.0-r1
Unaffected versions >= 2.6.0-r1
sys-kernel/wolk-sources on all architectures
Affected versions < 4.10_pre7-r2
Unaffected versions >= 4.10_pre7-r2
sys-kernel/xfs-sources on all architectures
Affected versions < 2.4.23-r1
Unaffected versions >= 2.4.23-r1

Background

The Linux kernel is responsible for memory management in a working system - to allow this, processes are allowed to allocate and unallocate memory.

Description

The memory subsystem allows for shrinking, growing, and moving of chunks of memory along any of the allocated memory areas which the kernel posesses.

A typical virtual memory area covers at least one memory page. An incorrect bound check discovered inside the do_mremap() kernel code performing remapping of a virtual memory area may lead to creation of a virtual memory area of 0 bytes length.

The problem is based on the general mremap flaw that remapping 2 pages from inside a VMA creates a memory hole of only one page in length but an additional VMA of two pages. In the case of a zero sized remapping request no VMA hole is created but an additional VMA descriptor of 0 bytes in length is created.

This advisory also addresses an information leak in the Linux RTC system.

Impact

Arbitrary code may be able to exploit this vulnerability and may disrupt the operation of other parts of the kernel memory management subroutines finally leading to unexpected behavior.

Since no special privileges are required to use the mremap(2) system call any process may misuse its unexpected behavior to disrupt the kernel memory management subsystem. Proper exploitation of this vulnerability may lead to local privilege escalation including execution of arbitrary code with kernel level access.

Proof-of-concept exploit code has been created and successfully tested, permitting root escalation on vulnerable systems. As a result, all users should upgrade their kernels to new or patched versions.

Workaround

There is no temporary workaround - a kernel upgrade is required. A list of unaffected kernels is provided along with this announcement.

Resolution

Users are encouraged to upgrade to the latest available sources for their system:

 $> emerge sync
 $> emerge -pv your-favourite-sources
 $> emerge your-favourite-sources
 $> # Follow usual procedure for compiling and installing a kernel.
 $> # If you use genkernel, run genkernel as you would do normally.

 $> # IF YOUR KERNEL IS MARKED as "remerge required!" THEN
 $> # YOU SHOULD UPDATE YOUR KERNEL EVEN IF PORTAGE
 $> # REPORTS THAT THE SAME VERSION IS INSTALLED.

References

Release Date
January 08, 2004

Latest Revision
January 08, 2004: 01

Severity
high

Exploitable
local

Bugzilla entries