Apache mod_python Denial of Service vulnerability — GLSA 200401-03

Apache's mod_python module could crash the httpd process if a specific, malformed query string was sent.

Affected Packages

www-apache/mod_python on all architectures
Affected versions < 2.7.10
Unaffected versions >= 2.7.10

Background

Mod_python is an Apache module that embeds the Python interpreter within the server allowing Python-based web-applications to be created.

Description

The Apache Foundation has reported that mod_python may be prone to Denial of Service attacks when handling a malformed query. Mod_python 2.7.9 was released to fix the vulnerability, however, because the vulnerability has not been fully fixed, version 2.7.10 has been released.

Users of mod_python 3.0.4 are not affected by this vulnerability.

Impact

Although there are no known public exploits known for this exploit, users are recommended to upgrade mod_python to ensure the security of their infrastructure.

Workaround

Mod_python 2.7.10 has been released to solve this issue; there is no immediate workaround.

Resolution

All users using mod_python 2.7.9 or below are recommended to update their mod_python installation:

 $> emerge sync
 $> emerge -pv ">=www-apache/mod_python-2.7.10"
 $> emerge ">=www-apache/mod_python-2.7.10"
 $> /etc/init.d/apache restart

References

Release Date
January 27, 2004

Latest Revision
December 30, 2007: 02

Severity
low

Exploitable
remote

Bugzilla entries