Linux kernel do_mremap local privilege escalation vulnerability — GLSA 200403-02

A critical security vulnerability has been found in recent Linux kernels by Paul Starzetz of iSEC Security Research which allows for local privilege escalations.

Affected Packages

sys-kernel/aa-sources on all architectures
Affected versions < 2.4.23-r1
Unaffected versions >= 2.4.23-r1
sys-kernel/alpha-sources on all architectures
Affected versions < 2.4.21-r4
Unaffected versions >= 2.4.21-r4
sys-kernel/ck-sources on all architectures
Affected versions < 2.6.2-r1
Unaffected versions = 2.4.24-r1, >= 2.6.2-r1
sys-kernel/compaq-sources on all architectures
Affected versions < 2.4.9.32.7-r2
Unaffected versions >= 2.4.9.32.7-r2
sys-kernel/development-sources on all architectures
Affected versions < 2.6.3_rc1
Unaffected versions >= 2.6.3_rc1
sys-kernel/gaming-sources on all architectures
Affected versions < 2.4.20-r8
Unaffected versions >= 2.4.20-r8
sys-kernel/gentoo-dev-sources on all architectures
Affected versions < 2.6.3_rc1
Unaffected versions >= 2.6.3_rc1
sys-kernel/gentoo-sources on all architectures
Affected versions < 2.4.22-r7
Unaffected versions = 2.4.19-r11, = 2.4.20-r12, >= 2.4.22-r7
sys-kernel/grsec-sources on all architectures
Affected versions < 2.4.24.1.9.13-r1
Unaffected versions >= 2.4.24.1.9.13-r1
sys-kernel/gs-sources on all architectures
Affected versions < 2.4.25_pre7-r2
Unaffected versions >= 2.4.25_pre7-r2
sys-kernel/hardened-sources on all architectures
Affected versions < 2.4.24-r1
Unaffected versions >= 2.4.24-r1
sys-kernel/hppa-dev-sources on all architectures
Affected versions < 2.6.2_p3-r1
Unaffected versions >= 2.6.2_p3-r1
sys-kernel/hppa-sources on all architectures
Affected versions < 2.4.24_p0-r1
Unaffected versions >= 2.4.24_p0-r1
sys-kernel/ia64-sources on all architectures
Affected versions < 2.4.24-r1
Unaffected versions >= 2.4.24-r1
sys-kernel/mips-prepatch-sources on all architectures
Affected versions < 2.4.25_pre6-r1
Unaffected versions >= 2.4.25_pre6-r1
sys-kernel/mips-sources on all architectures
Affected versions < 2.4.25_rc4
Unaffected versions >= 2.4.25_rc4
sys-kernel/mm-sources on all architectures
Affected versions < 2.6.3_rc1-r1
Unaffected versions >= 2.6.3_rc1-r1
sys-kernel/openmosix-sources on all architectures
Affected versions < 2.4.22-r4
Unaffected versions >= 2.4.22-r4
sys-kernel/pac-sources on all architectures
Affected versions < 2.4.23-r3
Unaffected versions >= 2.4.23-r3
sys-kernel/planet-ccrma-sources on all architectures
Affected versions < 2.4.21-r5
Unaffected versions >= 2.4.21-r5
sys-kernel/ppc-development-sources on all architectures
Affected versions < 2.6.3_rc1-r1
Unaffected versions >= 2.6.3_rc1-r1
sys-kernel/ppc-sources on all architectures
Affected versions < 2.4.24-r1
Unaffected versions >= 2.4.24-r1
sys-kernel/ppc-sources-benh on all architectures
Affected versions < 2.4.22-r5
Unaffected versions >= 2.4.22-r5
sys-kernel/ppc-sources-crypto on all architectures
Affected versions < 2.4.20-r3
Unaffected versions >= 2.4.20-r3
sys-kernel/ppc-sources-dev on all architectures
Affected versions < 2.4.24-r2
Unaffected versions >= 2.4.24-r2
sys-kernel/selinux-sources on all architectures
Affected versions < 2.4.24-r2
Unaffected versions >= 2.4.24-r2
sys-kernel/sparc-dev-sources on all architectures
Affected versions < 2.6.3_rc1
Unaffected versions >= 2.6.3_rc1
sys-kernel/sparc-sources on all architectures
Affected versions < 2.4.24-r2
Unaffected versions >= 2.4.24-r2
sys-kernel/usermode-sources on all architectures
Affected versions < 2.6.3-r1
Unaffected versions revision >= 2.4.24-r1, revision >= 2.4.26, >= 2.6.3-r1
sys-kernel/vanilla-prepatch-sources on all architectures
Affected versions < 2.4.25_rc4
Unaffected versions >= 2.4.25_rc4
sys-kernel/vanilla-sources on all architectures
Affected versions < 2.4.25
Unaffected versions >= 2.4.25
sys-kernel/win4lin-sources on all architectures
Affected versions < 2.6.2-r1
Unaffected versions = 2.4.23-r2, >= 2.6.2-r1
sys-kernel/wolk-sources on all architectures
Affected versions < 4.10_pre7-r3
Unaffected versions = 4.9-r4, >= 4.10_pre7-r3
sys-kernel/xfs-sources on all architectures
Affected versions < 2.4.24-r2
Unaffected versions >= 2.4.24-r2

Background

The Linux kernel is responsible for memory management in a working system - to allow this, processes are allowed to allocate and unallocate memory.

Description

The memory subsystem allows for shrinking, growing, and moving of chunks of memory along any of the allocated memory areas which the kernel posesses.

To accomplish this, the do_mremap code calls the do_munmap() kernel function to remove any old memory mappings in the new location - but, the code doesn't check the return value of the do_munmap() function which may fail if the maximum number of available virtual memory area descriptors has been exceeded.

Due to the missing return value check after trying to unmap the middle of the first memory area, the corresponding page table entries from the second new area are inserted into the page table locations described by the first old one, thus they are subject to page protection flags of the first area. As a result, arbitrary code can be executed.

Impact

Arbitrary code with normal non-super-user privelerges may be able to exploit this vulnerability and may disrupt the operation of other parts of the kernel memory management subroutines finally leading to unexpected behavior.

Since no special privileges are required to use the mremap() and mummap() system calls any process may misuse this unexpected behavior to disrupt the kernel memory management subsystem. Proper exploitation of this vulnerability may lead to local privilege escalation allowing for the execution of arbitrary code with kernel level root access.

Proof-of-concept exploit code has been created and successfully tested, permitting root escalation on vulnerable systems. As a result, all users should upgrade their kernels to new or patched versions.

Workaround

Users who are unable to upgrade their kernels may attempt to use "sysctl -w vm.max_map_count=1000000", however, this is a temporary fix which only solves the problem by increasing the number of memory areas that can be created by each process. Because of the static nature of this workaround, it is not recommended and users are urged to upgrade their systems to the latest avaiable patched sources.

Resolution

Users are encouraged to upgrade to the latest available sources for their system:

 # emerge sync
 # emerge -pv your-favourite-sources
 # emerge your-favourite-sources
 # # Follow usual procedure for compiling and installing a kernel.
 # # If you use genkernel, run genkernel as you would do normally.
 
 # # IF YOUR KERNEL IS MARKED as "remerge required!" THEN
 # # YOU SHOULD UPDATE YOUR KERNEL EVEN IF PORTAGE
 # # REPORTS THAT THE SAME VERSION IS INSTALLED.

References

Release Date
March 05, 2004

Latest Revision
May 22, 2006: 03

Severity
high

Exploitable
local

Bugzilla entries