Fetchmail 6.2.5 fixes a remote DoS — GLSA 200403-10

Fetchmail versions 6.2.4 and earlier can be crashed by sending a specially-crafted email to a fetchmail user.

Affected Packages

net-mail/fetchmail on all architectures
Affected versions <= 6.2.4
Unaffected versions >= 6.2.5

Background

Fetchmail is a utility that retrieves and forwards mail from remote systems using IMAP, POP, and other protocols.

Description

Fetchmail versions 6.2.4 and earlier can be crashed by sending a specially-crafted email to a fetchmail user. This problem occurs because Fetchmail does not properly allocate memory for long lines in an incoming email.

Impact

Fetchmail users who receive a malicious email may have their fetchmail program crash.

Workaround

While a workaround is not currently known for this issue, all users are advised to upgrade to the latest version of fetchmail.

Resolution

Fetchmail users should upgrade to version 6.2.5 or later:

 # emerge sync
 # emerge -pv ">=net-mail/fetchmail-6.2.5"
 # emerge ">=net-mail/fetchmail-6.2.5"

References

Release Date
March 30, 2004

Latest Revision
March 30, 2004: 01

Severity
normal

Exploitable
remote

Bugzilla entries