ipsec-tools contains an X.509 certificates vulnerability. — GLSA 200404-05

ipsec-tools contains a vulnerability that affects connections authenticated with X.509 certificates.

Affected Packages

net-firewall/ipsec-tools on the amd64 architecture
Affected versions <= 0.2.4
Unaffected versions >= 0.2.5

Background

From http://ipsec-tools.sourceforge.net/ :

"IPsec-Tools is a port of KAME's IPsec utilities to the Linux-2.6 IPsec implementation."

Description

racoon (a utility in the ipsec-tools package) does not verify digital signatures on Phase1 packets. This means that anybody holding the correct X.509 certificate would be able to establish a connection, even if they did not have the corresponding private key.

Impact

Since digital signatures are not verified by the racoon tool, an attacker may be able to connect to the VPN gateway and/or execute a man-in-the-middle attack.

Workaround

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.

Resolution

ipsec-tools users should upgrade to version 0.2.5 or later:

 # emerge sync
 
 # emerge -pv ">=net-firewall/ipsec-tools-0.2.5"
 # emerge ">=net-firewall/ipsec-tools-0.2.5"

References

Release Date
April 07, 2004

Latest Revision
April 07, 2004: 01

Severity
high

Exploitable
remote

Bugzilla entries