Multiple format string vulnerabilities in neon 0.24.4 and earlier — GLSA 200405-01

There are multiple format string vulnerabilities in libneon which may allow a malicious WebDAV server to execute arbitrary code.

Affected Packages

net-misc/neon on all architectures
Affected versions <= 0.24.4
Unaffected versions >= 0.24.5

Background

neon provides an HTTP and WebDAV client library.

Description

There are multiple format string vulnerabilities in libneon which may allow a malicious WebDAV server to execute arbitrary code under the context of the process using libneon.

Impact

An attacker may be able to execute arbitrary code under the context of the process using libneon.

Workaround

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.

Resolution

Neon users should upgrade to version 0.24.5 or later:

 # emerge sync

 # emerge -pv ">=net-misc/neon-0.24.5"
 # emerge ">=net-misc/neon-0.24.5"

References

Release Date
May 09, 2004

Latest Revision
May 09, 2004: 01

Severity
normal

Exploitable
remote

Bugzilla entries