KDE URI Handler Vulnerabilities — GLSA 200405-11

Vulnerabilities in KDE URI handlers makes your system vulnerable to various attacks.

Affected Packages

kde-base/kdelibs on all architectures
Affected versions <= 3.2.2
Unaffected versions >= 3.2.2-r1, = 3.1.5-r1

Background

The K Desktop Environment (KDE) is a powerful Free Software graphical desktop environment. KDE makes use of URI handlers to trigger various programs when specific URLs are received.

Description

The telnet, rlogin, ssh and mailto URI handlers in KDE do not check for '-' at the beginning of the hostname passed. By crafting a malicious URI and entice an user to click on it, it is possible to pass an option to the programs started by the handlers (typically telnet, kmail...).

Impact

If the attacker controls the options passed to the URI handling programs, it becomes possible for example to overwrite arbitrary files (possibly leading to denial of service), to open kmail on an attacker-controlled remote display or with an alternate configuration file (possibly leading to control of the user account).

Workaround

There is no known workaround at this time. All users are advised to upgrade to a corrected version of kdelibs.

Resolution

Users of KDE 3.1 should upgrade to the corrected version of kdelibs:

 # emerge sync

 # emerge -pv "=kde-base/kdelibs-3.1.5-r1"
 # emerge "=kde-base/kdelibs-3.1.5-r1"

Users of KDE 3.2 should upgrade to the latest available version of kdelibs:

 # emerge sync

 # emerge -pv ">=kde-base/kdelibs-3.2.2-r1"
 # emerge ">=kde-base/kdelibs-3.2.2-r1"

References

Release Date
May 19, 2004

Latest Revision
May 19, 2004: 01

Severity
normal

Exploitable
remote

Bugzilla entries