MPlayer, xine-lib: vulnerabilities in RTSP stream handling — GLSA 200405-24

Multiple vulnerabilities, including remotely exploitable buffer overflows, have been found in code common to MPlayer and the xine library.

Affected Packages

media-video/mplayer on all architectures
Affected versions < 1.0_pre4
Unaffected versions >= 1.0_pre4, <= 0.92-r1
media-libs/xine-lib on all architectures
Affected versions < 1_rc4
Unaffected versions >= 1_rc4, <= 0.9.13-r3

Background

MPlayer is a movie player capable of handling multiple multimedia file formats. xine-lib is a multimedia player library used by several graphical user interfaces, including xine-ui. They both use the same code to handle Real-Time Streaming Protocol (RTSP) streams from RealNetworks servers.

Description

Multiple vulnerabilities have been found and fixed in the RTSP handling code common to recent versions of these two packages. These vulnerabilities include several remotely exploitable buffer overflows.

Impact

A remote attacker, posing as a RTSP stream server, can execute arbitrary code with the rights of the user of the software playing the stream (MPlayer or any player using xine-lib). Another attacker may entice a user to use a maliciously crafted URL or playlist to achieve the same results.

Workaround

For MPlayer, there is no known workaround at this time. For xine-lib, you can delete the xineplug_inp_rtsp.so file.

Resolution

All users should upgrade to non-vulnerable versions of MPlayer and xine-lib:

 # emerge sync

 # emerge -pv ">=media-video/mplayer-1.0_pre4"
 # emerge ">=media-video/mplayer-1.0_pre4"

 # emerge -pv ">=media-libs/xine-lib-1_rc4"
 # emerge ">=media-libs/xine-lib-1_rc4"

References

Release Date
May 28, 2004

Latest Revision
May 28, 2004: 01

Severity
high

Exploitable
remote

Bugzilla entries