tla: Multiple vulnerabilities in included libneon — GLSA 200405-25

tla includes a vulnerable version of the neon library.

Affected Packages

dev-util/tla on all architectures
Affected versions <= 1.2-r1, = 1.2.1_pre1
Unaffected versions >= 1.2-r2

Background

GNU Arch (tla) is a revision control system suited for widely distributed development.

Description

Multiple format string vulnerabilities and a heap overflow vulnerability were discovered in the code of the neon library (GLSA 200405-01 and 200405-13). Current versions of the tla package include their own version of this library.

Impact

When connected to a malicious WebDAV server, these vulnerabilities could allow execution of arbitrary code with the rights of the user running tla.

Workaround

There is no known workaround at this time.

Resolution

All users of tla should upgrade to the latest stable version:

 # emerge sync

 # emerge -pv ">=dev-util/tla-1.2-r2"
 # emerge ">=dev-util/tla-1.2-r2"

References

Release Date
May 30, 2004

Latest Revision
June 02, 2004: 02

Severity
normal

Exploitable
remote

Bugzilla entries