A bug in mod_ssl may allow a remote attacker to execute remote code when Apache is configured a certain way.
|Package||net-www/mod_ssl on all architectures|
|Affected versions||< 2.8.18|
|Unaffected versions||>= 2.8.18|
|Package||www-servers/apache on all architectures|
|Affected versions||<= 2.0.49-r2|
|Unaffected versions||< 2.0, >= 2.0.49-r3|
Apache is the most popular Web server on the Internet. mod_ssl provides Secure Sockets Layer encryption and authentication to Apache 1.3. Apache 2 contains the functionality of mod_ssl.
A bug in the function ssl_util_uuencode_binary in ssl_util.c may lead to a remote buffer overflow on a server configured to use FakeBasicAuth that will trust a client certificate with an issuing CA with a subject DN longer than 6k.
Given the right server configuration, an attacker could cause a Denial of Service or execute code as the user running Apache, usually "apache". It is thought to be impossible to exploit this to execute code on the x86 platform, but the possibility for other platforms is unknown. This does not preclude a DoS on x86 systems.
A server should not be vulnerable if it is not configured to use FakeBasicAuth and to trust a client CA with a long subject DN.
Apache 1.x users should upgrade to the latest version of mod_ssl:
# emerge sync # emerge -pv ">=net-www/mod_ssl-2.8.18" # emerge ">=net-www/mod_ssl-2.8.18"
Apache 2.x users should upgrade to the latest version of Apache:
# emerge sync # emerge -pv ">=www-servers/apache-2.0.49-r3" # emerge ">=www-servers/apache-2.0.49-r3"
June 09, 2004
December 30, 2007: 03