giFT-FastTrack: remote denial of service attack — GLSA 200406-19

There is a vulnerability where a carefully crafted signal sent to the giFT-FastTrack plugin will cause the giFT daemon to crash.

Affected Packages

net-p2p/gift-fasttrack on all architectures
Affected versions <= 0.8.6
Unaffected versions >= 0.8.7

Background

giFT-FastTrack is a plugin for the giFT file-sharing application. It allows giFT users to connect to the fasttrack network to share files.

Description

Alan Fitton found a vulnerability in the giFT-FastTrack plugin in version 0.8.6 and earlier. It can be used to remotely crash the giFT daemon.

Impact

Attackers may use this vulnerability to perform a Denial of Service attack against the giFT daemon. There is no risk of code execution.

Workaround

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version.

Resolution

All users should upgrade to the latest available version of gift-fasttrack:

 # emerge sync
 
 # emerge -pv ">=net-p2p/gift-fasttrack-0.8.7"
 # emerge ">=net-p2p/gift-fasttrack-0.8.7"

References

Release Date
June 24, 2004

Latest Revision
May 22, 2006: 02

Severity
low

Exploitable
remote

Bugzilla entries