FreeS/WAN, Openswan, strongSwan: Vulnerabilities in certificate handling — GLSA 200406-20

FreeS/WAN, Openswan, strongSwan and Super-FreeS/WAN contain two bugs when authenticating PKCS#7 certificates. This could allow an attacker to authenticate with a fake certificate.

Affected Packages

net-misc/freeswan on all architectures
Affected versions < 2.04-r1
Unaffected versions >= 2.04-r1, = 1.99-r1
net-misc/openswan on all architectures
Affected versions < 2.1.4
Unaffected versions >= 2.1.4, = 1.0.6_rc1
net-misc/strongswan on all architectures
Affected versions < 2.1.3
Unaffected versions >= 2.1.3
net-misc/super-freeswan on all architectures
Affected versions <= 1.99.7.3
Unaffected versions

Background

FreeS/WAN, Openswan, strongSwan and Super-FreeS/WAN are Open Source implementations of IPsec for the Linux operating system. They are all based on the discontinued FreeS/WAN project.

Description

All these IPsec implementations have several bugs in the verify_x509cert() function, which performs certificate validation, that make them vulnerable to malicious PKCS#7 wrapped objects.

Impact

With a carefully crafted certificate payload an attacker can successfully authenticate against FreeS/WAN, Openswan, strongSwan or Super-FreeS/WAN, or make the daemon go into an endless loop.

Workaround

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version.

Resolution

All FreeS/WAN 1.9x users should upgrade to the latest stable version:

 # emerge sync
 
 # emerge -pv "=net-misc/freeswan-1.99-r1"
 # emerge "=net-misc/freeswan-1.99-r1"

All FreeS/WAN 2.x users should upgrade to the latest stable version:

 # emerge sync
 
 # emerge -pv ">=net-misc/freeswan-2.04-r1"
 # emerge ">=net-misc/freeswan-2.04-r1"

All Openswan 1.x users should upgrade to the latest stable version:

 # emerge sync
 
 # emerge -pv "=net-misc/openswan-1.0.6_rc1"
 # emerge "=net-misc/openswan-1.0.6_rc1"

All Openswan 2.x users should upgrade to the latest stable version:

 # emerge sync
 
 # emerge -pv ">=net-misc/openswan-2.1.4"
 # emerge ">=net-misc/openswan-2.1.4"

All strongSwan users should upgrade to the latest stable version:

 # emerge sync
 
 # emerge -pv ">=net-misc/strongswan-2.1.3"
 # emerge ">=net-misc/strongswan-2.1.3"

All Super-FreeS/WAN users should migrate to the latest stable version of Openswan. Note that Portage will force a move for Super-FreeS/WAN users to Openswan.

 # emerge sync
 
 # emerge -pv "=net-misc/openswan-1.0.6_rc1"
 # emerge "=net-misc/openswan-1.0.6_rc1"

References

Release Date
June 25, 2004

Latest Revision
May 22, 2006: 02

Severity
normal

Exploitable
remote

Bugzilla entries