mod_ssl: Format string vulnerability — GLSA 200407-18

A bug in mod_ssl may allow a remote attacker to execute arbitrary code when Apache is configured to use mod_ssl and mod_proxy.

Affected Packages

net-www/mod_ssl on all architectures
Affected versions <= 2.8.18
Unaffected versions >= 2.8.19

Background

mod_ssl provides Secure Sockets Layer encryption and authentication to Apache 1.3.

Description

A bug in ssl_engine_ext.c makes mod_ssl vulnerable to a ssl_log() related format string vulnerability in the mod_proxy hook functions.

Impact

Given the right server configuration, an attacker could execute code as the user running Apache, usually "apache".

Workaround

A server should not be vulnerable if it is not using both mod_ssl and mod_proxy. Otherwise there is no workaround other than to disable mod_ssl.

Resolution

All mod_ssl users should upgrade to the latest version:

 # emerge sync

 # emerge -pv ">=net-www/mod_ssl-2.8.19"
 # emerge ">=net-www/mod_ssl-2.8.19"

References

Release Date
July 22, 2004

Latest Revision
July 22, 2004: 01

Severity
normal

Exploitable
remote

Bugzilla entries