Pavuk: Digest authentication helper buffer overflow — GLSA 200407-19

Pavuk contains a bug that can allow an attacker to run arbitrary code.

Affected Packages

net-misc/pavuk on all architectures
Affected versions <= 0.9.28-r2
Unaffected versions >= 0.9.28-r3

Background

Pavuk is web spider and website mirroring tool.

Description

Pavuk contains several buffer overflow vulnerabilities in the code handling digest authentication.

Impact

An attacker could cause a buffer overflow, leading to arbitrary code execution with the rights of the user running Pavuk.

Workaround

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version of Pavuk.

Resolution

All Pavuk users should upgrade to the latest version:

 # emerge sync
 
 # emerge -pv ">=net-misc/pavuk-0.9.28-r3"
 # emerge ">=net-misc/pavuk-0.9.28-r3"

References

Release Date
July 26, 2004

Latest Revision
May 22, 2006: 02

Severity
normal

Exploitable
remote

Bugzilla entries