MPlayer: GUI filename handling overflow — GLSA 200408-01

When compiled with GUI support MPlayer is vulnerable to a remotely exploitable buffer overflow attack.

Affected Packages

media-video/mplayer on all architectures
Affected versions < 1.0_pre4-r7
Unaffected versions >= 1.0_pre4-r7

Background

MPlayer is a media player capable of handling multiple multimedia file formats.

Description

The MPlayer GUI code contains several buffer overflow vulnerabilities, and at least one in the TranslateFilename() function is exploitable.

Impact

By enticing a user to play a file with a carefully crafted filename an attacker could execute arbitrary code with the permissions of the user running MPlayer.

Workaround

To work around this issue, users can compile MPlayer without GUI support by disabling the gtk USE flag. All users are encouraged to upgrade to the latest available version of MPlayer.

Resolution

All MPlayer users should upgrade to the latest version:

 # emerge sync
 
 # emerge -pv ">=media-video/mplayer-1.0_pre4-r7"
 # emerge ">=media-video/mplayer-1.0_pre4-r7"

References

Release Date
August 01, 2004

Latest Revision
May 22, 2006: 02

Severity
normal

Exploitable
remote

Bugzilla entries