Horde-IMP: Input validation vulnerability for Internet Explorer users — GLSA 200408-07

An input validation vulnerability has been discovered in Horde-IMP. This only affects users of Internet Explorer.

Affected Packages

www-apps/horde-imp on all architectures
Affected versions <= 3.2.4
Unaffected versions >= 3.2.5

Background

Horde-IMP is the Internet Messaging Program. It is written in PHP and provides webmail access to IMAP and POP3 accounts.

Description

Horde-IMP fails to properly sanitize email messages that contain malicious HTML or script code so that it is not safe for users of Internet Explorer when using the inline MIME viewer for HTML messages.

Impact

By enticing a user to read a specially crafted e-mail, an attacker can execute arbitrary scripts running in the context of the victim's browser. This could lead to a compromise of the user's webmail account, cookie theft, etc.

Workaround

Do not use Internet Explorer to access Horde-IMP.

Resolution

All Horde-IMP users should upgrade to the latest stable version:

 # emerge sync
 
 # emerge -pv ">=www-apps/horde-imp-3.2.5"
 # emerge ">=www-apps/horde-imp-3.2.5"

References

Release Date
August 10, 2004

Latest Revision
May 22, 2006: 02

Severity
normal

Exploitable
remote

Bugzilla entries