Cfengine: RSA Authentication Heap Corruption — GLSA 200408-08

Cfengine is vulnerable to a remote root exploit from clients in AllowConnectionsFrom.

Affected packages

net-misc/cfengine on all architectures
Affected versions <= 2.1.7
Unaffected versions >= 2.1.8
< 2.0.0


Cfengine is an agent/software robot and a high level policy language for building expert systems to administrate and configure large computer networks.


Two vulnerabilities have been found in cfservd. One is a buffer overflow in the AuthenticationDialogue function and the other is a failure to check the proper return value of the ReceiveTransaction function.


An attacker could use the buffer overflow to execute arbitrary code with the permissions of the user running cfservd, which is usually the root user. However, before such an attack could be mounted, the IP-based ACL would have to be bypassed. With the second vulnerability, an attacker could cause a denial of service attack.


There is no known workaround at this time. All users are encouraged to upgrade to the latest available version of Cfengine. (It should be noted that disabling cfservd will work around this particular problem. However, in many cases, doing so will cripple your Cfengine setup. Upgrading is strongly recommended.)


All Cfengine users should upgrade to the latest version:

 # emerge sync
 # emerge -pv ">=net-misc/cfengine-2.1.8"
 # emerge ">=net-misc/cfengine-2.1.8"


Release date
August 10, 2004

Latest revision
May 22, 2006: 05



Bugzilla entries