ImageMagick, imlib, imlib2: BMP decoding buffer overflows — GLSA 200409-12

ImageMagick, imlib and imlib2 contain exploitable buffer overflow vulnerabilities in the BMP image processing code.

Affected Packages

media-gfx/imagemagick on all architectures
Affected versions < 6.0.7.1
Unaffected versions >= 6.0.7.1
media-libs/imlib on all architectures
Affected versions < 1.9.14-r2
Unaffected versions >= 1.9.14-r2
media-libs/imlib2 on all architectures
Affected versions < 1.1.2
Unaffected versions >= 1.1.2

Background

ImageMagick is a suite of image manipulation utilities and libraries used for a wide variety of image formats. imlib is a general image loading and rendering library.

Description

Due to improper bounds checking, ImageMagick and imlib are vulnerable to a buffer overflow when decoding runlength-encoded bitmaps. This bug can be exploited using a specially-crafted BMP image and could potentially allow remote code execution when this image is decoded by the user.

Impact

A specially-crafted runlength-encoded BMP could lead ImageMagick and imlib to crash or potentially execute arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All ImageMagick users should upgrade to the latest version:

 # emerge sync

 # emerge -pv ">=media-gfx/imagemagick-6.0.7.1"
 # emerge ">=media-gfx/imagemagick-6.0.7.1"

All imlib users should upgrade to the latest version:

 # emerge sync

 # emerge -pv ">=media-libs/imlib-1.9.14-r2"
 # emerge ">=media-libs/imlib-1.9.14-r2"

All imlib2 users should upgrade to the latest version:

 # emerge sync

 # emerge -pv ">=media-libs/imlib2-1.1.2"
 # emerge ">=media-libs/imlib2-1.1.2"

References

Release Date
September 08, 2004

Latest Revision
September 08, 2004: 01

Severity
normal

Exploitable
remote

Bugzilla entries