LessTif: Integer and stack overflows in libXpm — GLSA 200410-09

Multiple vulnerabilities have been discovered in libXpm, which is included in LessTif, that can potentially lead to remote code execution.

Affected Packages

x11-libs/lesstif on all architectures
Affected versions < 0.93.97
Unaffected versions >= 0.93.97

Background

LessTif is a clone of OSF/Motif, which is the standard user interface toolkit available on Unix and Linux.

Description

Chris Evans has discovered various integer and stack overflows in libXpm, which is shipped as a part of the X Window System. LessTif, an application that includes this library, is susceptible to the same issues.

Impact

A carefully-crafted XPM file could crash applications that are linked against libXpm, such as LessTif, potentially allowing the execution of arbitrary code with the privileges of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All LessTif users should upgrade to the latest version:

 # emerge sync

 # emerge -pv ">=x11-libs/lesstif-0.93.97"
 # emerge ">=x11-libs/lesstif-0.93.97"

References

Release Date
October 09, 2004

Latest Revision
October 09, 2004: 01

Severity
normal

Exploitable
remote

Bugzilla entries