kdelibs, kdebase: Multiple vulnerabilities — GLSA 200412-16

kdelibs and kdebase contain a flaw allowing password disclosure when creating a link to a remote file. Furthermore Konqueror is vulnerable to window injection.

Affected Packages

kde-base/kdelibs on all architectures
Affected versions < 3.3.2-r1
Unaffected versions revision >= 3.2.3-r4, revision >= 3.3.1-r2, >= 3.3.2-r1
kde-base/kdebase on all architectures
Affected versions < 3.3.2-r1
Unaffected versions revision >= 3.2.3-r3, revision >= 3.3.1-r2

Background

KDE is a feature-rich graphical desktop environment for Linux and Unix-like Operating Systems. The KDE core libraries (kdebase and kdelibs) provide native support for many protocols. Konqueror is the KDE web browser and filemanager.

Description

Daniel Fabian discovered that the KDE core libraries contain a flaw allowing password disclosure by making a link to a remote file. When creating this link, the resulting URL contains authentication credentials used to access the remote file (CAN 2004-1171).

The Konqueror webbrowser allows websites to load webpages into a window or tab currently used by another website (CAN-2004-1158).

Impact

A malicious user could have access to the authentication credentials of other users depending on the file permissions.

A malicious website could use the window injection vulnerability to load content in a window apparently belonging to another website.

Workaround

There is no known workaround at this time.

Resolution

All kdelibs users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=kde-base/kdelibs-3.2.3-r4"

All kdebase users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=kde-base/kdebase-3.2.3-r3"

References

Release Date
December 19, 2004

Latest Revision
December 19, 2004: 01

Severity
normal

Exploitable
remote and local

Bugzilla entries