ViewCVS: Information leak and XSS vulnerabilities — GLSA 200412-26

ViewCVS is vulnerable to an information leak and to cross-site scripting (XSS) issues.

Affected Packages

www-apps/viewcvs on all architectures
Affected versions <= 0.9.2_p20041207
Unaffected versions >= 0.9.2_p20041207-r1

Background

ViewCVS is a browser interface for viewing CVS and Subversion version control repositories through a web browser.

Description

The tar export functions in ViewCVS bypass the 'hide_cvsroot' and 'forbidden' settings and therefore expose information that should be kept secret (CAN-2004-0915). Furthermore, some error messages in ViewCVS do not filter user-provided information, making it vulnerable to a cross-site scripting attack (CAN-2004-1062).

Impact

By using the tar export functions, a remote attacker could access information that is configured as restricted. Through the use of a malicious request, an attacker could also inject and execute malicious script code, potentially compromising another user's browser.

Workaround

There is no known workaround at this time.

Resolution

All ViewCVS users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/viewcvs-0.9.2_p20041207-r1"

References

Release Date
December 28, 2004

Latest Revision
December 28, 2004: 01

Severity
low

Exploitable
remote

Bugzilla entries