TikiWiki: Arbitrary command execution — GLSA 200501-12

A bug in TikiWiki allows certain users to upload and execute malicious PHP scripts.

Affected Packages

www-apps/tikiwiki on all architectures
Affected versions < 1.8.4.1
Unaffected versions >= 1.8.4.1

Background

TikiWiki is a web-based groupware and content management system (CMS), using PHP, ADOdb and Smarty.

Description

TikiWiki lacks a check on uploaded images in the Wiki edit page.

Impact

A malicious user could run arbitrary commands on the server by uploading and calling a PHP script.

Workaround

There is no known workaround at this time.

Resolution

All TikiWiki users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/tikiwiki-1.8.4.1"

Note: Users with the vhosts USE flag set should manually use webapp-config to finalize the update.

References

Release Date
January 10, 2005

Latest Revision
May 22, 2006: 03

Severity
high

Exploitable
remote

Bugzilla entries