KPdf, KOffice: More vulnerabilities in included Xpdf — GLSA 200501-17

KPdf and KOffice both include vulnerable Xpdf code to handle PDF files, making them vulnerable to the execution of arbitrary code if a user is enticed to view a malicious PDF file.

Affected Packages

app-office/koffice on all architectures
Affected versions < 1.3.5-r1
Unaffected versions >= 1.3.5-r1
kde-base/kdegraphics on all architectures
Affected versions < 3.3.2-r1
Unaffected versions >= 3.3.2-r1, revision >= 3.2.3-r3

Background

KPdf is a KDE-based PDF viewer included in the kdegraphics package. KOffice is an integrated office suite for KDE.

Description

KPdf and KOffice both include Xpdf code to handle PDF files. Xpdf is vulnerable to multiple new integer overflows, as described in GLSA 200412-24.

Impact

An attacker could entice a user to open a specially-crafted PDF file, potentially resulting in the execution of arbitrary code with the rights of the user running the affected utility.

Workaround

There is no known workaround at this time.

Resolution

All KPdf users should upgrade to the latest version of kdegraphics:

 # emerge --sync
 # emerge --ask --oneshot --verbose kde-base/kdegraphics

All KOffice users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose app-office/koffice

References

Release Date
January 11, 2005

Latest Revision
January 12, 2005: 02

Severity
normal

Exploitable
remote

Bugzilla entries