KDE FTP KIOslave: Command injection — GLSA 200501-18

The FTP KIOslave contains a bug allowing users to execute arbitrary FTP commands.

Affected Packages

kde-base/kdelibs on all architectures
Affected versions < 3.3.2-r2
Unaffected versions >= 3.3.2-r2, revision >= 3.2.3-r5

Background

KDE is a feature-rich graphical desktop environment for Linux and Unix-like Operating Systems. KDE provided KIOslaves for many protocols in the kdelibs package, one of them being FTP. These are used by KDE applications such as Konqueror.

Description

The FTP KIOslave fails to properly parse URL-encoded newline characters.

Impact

An attacker could exploit this to execute arbitrary FTP commands on the server and due to similiarities between the FTP and the SMTP protocol, this vulnerability also allows an attacker to connect to a SMTP server and issue arbitrary commands, for example sending an email.

Workaround

There is no known workaround at this time.

Resolution

All kdelibs users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose kde-base/kdelibs

References

Release Date
January 11, 2005

Latest Revision
January 12, 2005: 02

Severity
normal

Exploitable
remote

Bugzilla entries