tnftp: Arbitrary file overwriting — GLSA 200501-24

tnftp fails to validate filenames when downloading files, making it vulnerable to arbitrary file overwriting.

Affected Packages

net-ftp/tnftp on all architectures
Affected versions < 20050103
Unaffected versions >= 20050103

Background

tnftp is a NetBSD FTP client with several advanced features.

Description

The 'mget' function in cmds.c lacks validation of the filenames that are supplied by the server.

Impact

An attacker running an FTP server could supply clients with malicious filenames, potentially allowing the overwriting of arbitrary files with the permission of the connected user.

Workaround

There is no known workaround at this time.

Resolution

All tnftp users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-ftp/tnftp-20050103"

References

Release Date
January 14, 2005

Latest Revision
January 14, 2005: 01

Severity
normal

Exploitable
remote

Bugzilla entries