CUPS: Stack overflow in included Xpdf code — GLSA 200501-30

CUPS includes Xpdf code and therefore is vulnerable to the recent stack overflow issue, potentially resulting in the remote execution of arbitrary code.

Affected Packages

net-print/cups on all architectures
Affected versions < 1.1.23-r1
Unaffected versions >= 1.1.23-r1

Background

The Common UNIX Printing System (CUPS) is a cross-platform print spooler. It makes use of Xpdf code to handle PDF files.

Description

The Decrypt::makeFileKey2 function in Xpdf's Decrypt.cc insufficiently checks boundaries when processing /Encrypt /Length tags in PDF files (GLSA 200501-28).

Impact

This issue could be exploited by a remote attacker to execute arbitrary code by sending a malicious print job to a CUPS spooler.

Workaround

There is no known workaround at this time.

Resolution

All CUPS users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-print/cups-1.1.23-r1"

References

Release Date
January 22, 2005

Latest Revision
January 22, 2005: 01

Severity
normal

Exploitable
remote

Bugzilla entries