KPdf, KOffice: Stack overflow in included Xpdf code — GLSA 200501-32

KPdf and KOffice both include vulnerable Xpdf code to handle PDF files, making them vulnerable to the execution of arbitrary code.

Affected Packages

app-office/koffice on all architectures
Affected versions < 1.3.5-r2
Unaffected versions >= 1.3.5-r2
kde-base/kdegraphics on all architectures
Affected versions < 3.3.2-r2
Unaffected versions >= 3.3.2-r2, revision >= 3.2.3-r4

Background

KPdf is a KDE-based PDF viewer included in the kdegraphics package. KOffice is an integrated office suite for KDE.

Description

KPdf and KOffice both include Xpdf code to handle PDF files. Xpdf is vulnerable to a new stack overflow, as described in GLSA 200501-28.

Impact

An attacker could entice a user to open a specially-crafted PDF file, potentially resulting in the execution of arbitrary code with the rights of the user running the affected application.

Workaround

There is no known workaround at this time.

Resolution

All KPdf users should upgrade to the latest version of kdegraphics:

 # emerge --sync
 # emerge --ask --oneshot --verbose kde-base/kdegraphics

All KOffice users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose app-office/koffice

References

Release Date
January 23, 2005

Latest Revision
January 23, 2005: 01

Severity
normal

Exploitable
remote

Bugzilla entries