Newspost: Buffer overflow vulnerability — GLSA 200502-05

A buffer overflow can be exploited to crash Newspost remotely and potentially execute arbitrary code.

Affected Packages

net-nntp/newspost on all architectures
Affected versions < 2.1.1-r1
Unaffected versions revision >= 2.0-r1, >= 2.1.1-r1

Background

Newspost is a Usenet News binary autoposter.

Description

Niels Heinen has discovered a buffer overflow in the socket_getline() function of Newspost, which can be triggered by providing long strings that do not end with a newline character.

Impact

A remote attacker could setup a malicious NNTP server and entice a Newspost user to post to it, leading to the crash of the Newspost process and potentially the execution of arbitrary code with the rights of the Newspost user.

Workaround

There is no known workaround at this time.

Resolution

All Newspost users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-nntp/newspost-2.0-r1"

References

Release Date
February 03, 2005

Latest Revision
February 21, 2005: 02

Severity
normal

Exploitable
remote

Bugzilla entries