LessTif: Multiple vulnerabilities in libXpm — GLSA 200502-06

Multiple vulnerabilities have been discovered in libXpm, which is included in LessTif, that can potentially lead to remote code execution.

Affected Packages

x11-libs/lesstif on all architectures
Affected versions < 0.94.0
Unaffected versions >= 0.94.0

Background

LessTif is a clone of OSF/Motif, which is a standard user interface toolkit available on Unix and Linux.

Description

Multiple vulnerabilities, including buffer overflows, out of bounds memory access and directory traversals, have been discovered in libXpm, which is shipped as a part of the X Window System. LessTif, an application that includes libXpm, suffers from the same issues.

Impact

A carefully-crafted XPM file could crash applications making use of the LessTif toolkit, potentially allowing the execution of arbitrary code with the privileges of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All LessTif users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=x11-libs/lesstif-0.94.0"

References

Release Date
February 06, 2005

Latest Revision
February 06, 2005: 01

Severity
normal

Exploitable
remote

Bugzilla entries