BidWatcher: Format string vulnerability — GLSA 200503-06

BidWatcher is vulnerable to a format string vulnerability, potentially allowing arbitrary code execution.

Affected Packages

net-misc/bidwatcher on all architectures
Affected versions < 1.3.17
Unaffected versions >= 1.3.17

Background

BidWatcher is a free auction tool for eBay users to keep track of their auctions.

Description

Ulf Harnhammar discovered a format string vulnerability in "netstuff.cpp".

Impact

Remote attackers can potentially exploit this vulnerability by sending specially crafted responses via an eBay HTTP server or a man-in-the-middle attack to execute arbitrary malicious code.

Workaround

There is no known workaround at this time.

Resolution

All BidWatcher users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/bidwatcher-1.13.17"

References

Release Date
March 03, 2005

Latest Revision
March 03, 2005: 01

Severity
normal

Exploitable
remote

Bugzilla entries