OpenMotif, LessTif: New libXpm buffer overflows — GLSA 200503-08

A new vulnerability has been discovered in libXpm, which is included in OpenMotif and LessTif, that can potentially lead to remote code execution.

Affected Packages

x11-libs/openmotif on all architectures
Affected versions < 2.2.3-r3
Unaffected versions >= 2.2.3-r3, revision >= 2.1.30-r9
x11-libs/lesstif on all architectures
Affected versions < 0.94.0-r2
Unaffected versions >= 0.94.0-r2

Background

LessTif is a clone of OSF/Motif, which is a standard user interface toolkit available on Unix and Linux. OpenMotif also provides a free version of the Motif toolkit for open source applications.

Description

Chris Gilbert discovered potentially exploitable buffer overflow cases in libXpm that weren't fixed in previous libXpm security advisories.

Impact

A carefully-crafted XPM file could crash applications making use of the OpenMotif or LessTif toolkits, potentially allowing the execution of arbitrary code with the privileges of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All OpenMotif users should upgrade to an unaffected version:

 # emerge --sync
 # emerge --ask --oneshot --verbose x11-libs/openmotif

All LessTif users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=x11-libs/lesstif-0.94.0-r2"

References

Release Date
March 04, 2005

Latest Revision
March 04, 2005: 01

Severity
normal

Exploitable
remote

Bugzilla entries