ImageMagick: Filename handling vulnerability — GLSA 200503-11

A format string vulnerability exists in ImageMagick that may allow an attacker to execute arbitrary code.

Affected Packages

media-gfx/imagemagick on all architectures
Affected versions < 6.2.0.4
Unaffected versions >= 6.2.0.4

Background

ImageMagick is a collection of tools and libraries for manipulating a wide variety of image formats.

Description

Tavis Ormandy of the Gentoo Linux Security Audit Team has identified a flaw in the handling of filenames by the ImageMagick utilities.

Impact

Successful exploitation may disrupt web applications that depend on ImageMagick for image processing, potentially executing arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All ImageMagick users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-gfx/imagemagick-6.2.0.4"

References

Release Date
March 06, 2005

Latest Revision
May 22, 2006: 02

Severity
normal

Exploitable
remote

Bugzilla entries