IPsec-Tools: racoon Denial of Service — GLSA 200503-33

IPsec-Tools' racoon is affected by a remote Denial of Service vulnerability.

Affected Packages

net-firewall/ipsec-tools on all architectures
Affected versions < 0.5-r1
Unaffected versions revision >= 0.4-r1, >= 0.5-r1

Background

IPsec-Tools is a port of KAME's implementation of the IPsec utilities. It contains a collection of network monitoring tools, including racoon, ping, and ping6.

Description

Sebastian Krahmer has reported a potential remote Denial of Service vulnerability in the ISAKMP header parsing code of racoon.

Impact

An attacker could possibly cause a Denial of Service of racoon using a specially crafted ISAKMP packet.

Workaround

There is no known workaround at this time.

Resolution

All IPsec-Tools users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-firewall/ipsec-tools-0.4-r1"

References

Release Date
March 25, 2005

Latest Revision
March 25, 2005: 01

Severity
normal

Exploitable
remote

Bugzilla entries