Sylpheed, Sylpheed-claws: Buffer overflow on message display — GLSA 200504-02

Sylpheed and Sylpheed-claws contain a vulnerability that can be triggered when displaying messages with specially crafted attachments.

Affected Packages

mail-client/sylpheed on all architectures
Affected versions < 1.0.4
Unaffected versions >= 1.0.4
mail-client/sylpheed-claws on all architectures
Affected versions < 1.0.4
Unaffected versions >= 1.0.4

Background

Sylpheed is a lightweight email client and newsreader. Sylpheed-claws is a 'bleeding edge' version of Sylpheed.

Description

Sylpheed and Sylpheed-claws fail to properly handle messages containing attachments with MIME-encoded filenames.

Impact

An attacker can send a malicious email message which, when displayed, would cause the program to crash, potentially allowing the execution of arbitrary code with the privileges of the user running the software.

Workaround

There is no known workaround at this time.

Resolution

All Sylpheed users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-client/sylpheed-1.0.4"

All Sylpheed-claws users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-client/sylpheed-claws-1.0.4"

References

Release Date
April 02, 2005

Latest Revision
April 02, 2005: 01

Severity
normal

Exploitable
remote

Bugzilla entries