Horde Framework: Multiple XSS vulnerabilities — GLSA 200505-01

Various modules of the Horde Framework are vulnerable to multiple cross-site scripting (XSS) vulnerabilities.

Affected Packages

www-apps/horde-vacation on all architectures
Affected versions < 2.2.2
Unaffected versions >= 2.2.2
www-apps/horde-turba on all architectures
Affected versions < 1.2.5
Unaffected versions >= 1.2.5
www-apps/horde-passwd on all architectures
Affected versions < 2.2.2
Unaffected versions >= 2.2.2
www-apps/horde-nag on all architectures
Affected versions < 1.1.3
Unaffected versions >= 1.1.3
www-apps/horde-mnemo on all architectures
Affected versions < 1.1.4
Unaffected versions >= 1.1.4
www-apps/horde-kronolith on all architectures
Affected versions < 1.1.4
Unaffected versions >= 1.1.4
www-apps/horde-imp on all architectures
Affected versions < 3.2.8
Unaffected versions >= 3.2.8
www-apps/horde-accounts on all architectures
Affected versions < 2.1.2
Unaffected versions >= 2.1.2
www-apps/horde-forwards on all architectures
Affected versions < 2.2.2
Unaffected versions >= 2.2.2
www-apps/horde-chora on all architectures
Affected versions < 1.2.3
Unaffected versions >= 1.2.3
www-apps/horde on all architectures
Affected versions < 2.2.8
Unaffected versions >= 2.2.8

Background

The Horde Framework is a PHP based framework for building web applications. It provides many modules including calendar, address book, CVS viewer and Internet Messaging Program.

Description

Cross-site scripting vulnerabilities have been discovered in various modules of the Horde Framework.

Impact

These vulnerabilities could be exploited by an attacker to execute arbitrary HTML and script code in context of the victim's browser.

Workaround

There is no known workaround at this time.

Resolution

All Horde users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/horde-2.2.8"

All Horde Vacation users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/horde-vacation-2.2.2"

All Horde Turba users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/horde-turba-1.2.5"

All Horde Passwd users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/horde-passwd-2.2.2"

All Horde Nag users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/horde-nag-1.1.3"

All Horde Mnemo users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/horde-mnemo-1.1.4"

All Horde Kronolith users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/horde-kronolith-1.1.4"

All Horde IMP users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/horde-imp-3.2.8"

All Horde Accounts users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/horde-accounts-2.1.2"

All Horde Forwards users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/horde-forwards-2.2.2"

All Horde Chora users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/horde-chora-1.2.3"

References

Release Date
May 01, 2005

Latest Revision
May 01, 2005: 01

Severity
low

Exploitable
remote

Bugzilla entries