The GnuTLS library is vulnerable to Denial of Service attacks.
|Package||net-libs/gnutls on all architectures|
|Affected versions||< 1.2.3|
|Unaffected versions||>= 1.2.3
revision >= 1.0.25
GnuTLS is a free TLS 1.0 and SSL 3.0 implementation for the GNU project.
A vulnerability has been discovered in the record packet parsing in the GnuTLS library. Additionally, a flaw was also found in the RSA key export functionality.
A remote attacker could exploit this vulnerability and cause a Denial of Service to any application that utilizes the GnuTLS library.
There is no known workaround at this time.
All GnuTLS users should remove the existing installation and upgrade to the latest version:
# emerge --sync # emerge --unmerge gnutls # emerge --ask --oneshot --verbose net-libs/gnutls
Due to small API changes with the previous version, please do the following to ensure your applications are using the latest GnuTLS that you just emerged.
# revdep-rebuild --soname-regexp libgnutls.so.1[0-1]
Previously exported RSA keys can be fixed by executing the following command on the key files:
# certtool -k infile outfile
May 09, 2005
May 09, 2005: 01