PostgreSQL: Multiple vulnerabilities — GLSA 200505-12

PostgreSQL is vulnerable to Denial of Service attacks and possibly allows unprivileged users to gain administrator rights.

Affected Packages

dev-db/postgresql on all architectures
Affected versions < 7.3.10, < 7.4.7-r2, < 8.0.2-r1
Unaffected versions = 7.3*, = 7.4*, revision >= 8.0.1-r3, >= 8.0.2-r1

Background

PostgreSQL is a SQL compliant, open source object-relational database management system.

Description

PostgreSQL gives public EXECUTE access to a number of character conversion routines, but doesn't validate the given arguments (CAN-2005-1409). It has also been reported that the contrib/tsearch2 module of PostgreSQL misdeclares the return value of some functions as "internal" (CAN-2005-1410).

Impact

An attacker could call the character conversion routines with specially setup arguments to crash the backend process of PostgreSQL or to potentially gain administrator rights. A malicious user could also call the misdeclared functions of the contrib/tsearch2 module, resulting in a Denial of Service or other, yet uninvestigated, impacts.

Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL users should update to the latest available version and follow the guide at http://www.postgresql.o rg/about/news.315

 # emerge --sync
 # emerge --ask --oneshot --verbose dev-db/postgresql

References

Release Date
May 15, 2005

Latest Revision
June 26, 2007: 04

Severity
normal

Exploitable
remote

Bugzilla entries