PostgreSQL is vulnerable to Denial of Service attacks and possibly allows unprivileged users to gain administrator rights.
|Package||dev-db/postgresql on all architectures|
|Affected versions||< 7.3.10
|Unaffected versions||= 7.3*
revision >= 8.0.1-r3
PostgreSQL is a SQL compliant, open source object-relational database management system.
PostgreSQL gives public EXECUTE access to a number of character conversion routines, but doesn't validate the given arguments (CAN-2005-1409). It has also been reported that the contrib/tsearch2 module of PostgreSQL misdeclares the return value of some functions as "internal" (CAN-2005-1410).
An attacker could call the character conversion routines with specially setup arguments to crash the backend process of PostgreSQL or to potentially gain administrator rights. A malicious user could also call the misdeclared functions of the contrib/tsearch2 module, resulting in a Denial of Service or other, yet uninvestigated, impacts.
There is no known workaround at this time.
All PostgreSQL users should update to the latest available version and follow the guide at http://www.postgresql.o rg/about/news.315
# emerge --sync # emerge --ask --oneshot --verbose dev-db/postgresql
May 15, 2005
June 26, 2007: 04