Binutils, elfutils: Buffer overflow — GLSA 200506-01

Various utilities from the GNU Binutils and elfutils packages are vulnerable to a heap based buffer overflow, potentially resulting in the execution of arbitrary code.

Affected Packages

dev-libs/elfutils on all architectures
Affected versions < 0.108
Unaffected versions >= 0.108
sys-devel/binutils on all architectures
Affected versions < 2.16-r1
Unaffected versions revision >= 2.14.90.0.8-r3, revision >= 2.15.90.0.1.1-r5, revision >= 2.15.90.0.3-r5, revision >= 2.15.91.0.2-r2, revision >= 2.15.92.0.2-r10, >= 2.16-r1

Background

The GNU Binutils are a collection of tools to create, modify and analyse binary files. Many of the files use BFD, the Binary File Descriptor library, to do low-level manipulation. Elfutils provides a library and utilities to access, modify and analyse ELF objects.

Description

Tavis Ormandy and Ned Ludd of the Gentoo Linux Security Audit Team discovered an integer overflow in the BFD library and elfutils, resulting in a heap based buffer overflow.

Impact

Successful exploitation would require a user to access a specially crafted binary file, resulting in the execution of arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All GNU Binutils users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose sys-devel/binutils

All elfutils users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/elfutils-0.108"

References

Release Date
June 01, 2005

Latest Revision
May 22, 2006: 02

Severity
normal

Exploitable
remote

Bugzilla entries