Wordpress contains SQL injection and XSS vulnerabilities.
|Package||www-apps/wordpress on all architectures|
|Affected versions||< 126.96.36.199|
|Unaffected versions||>= 188.8.131.52|
WordPress is a PHP and MySQL based content management and publishing system.
Due to a lack of input validation, WordPress is vulnerable to SQL injection and XSS attacks.
An attacker could use the SQL injection vulnerabilities to gain information from the database. Furthermore the cross-site scripting issues give an attacker the ability to inject and execute malicious script code or to steal cookie-based authentication credentials, potentially compromising the victim's browser.
There is no known workaround at this time.
All Wordpress users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-apps/wordpress-184.108.40.206"