SpamAssassin 3, Vipul's Razor: Denial of Service vulnerability — GLSA 200506-17

SpamAssassin and Vipul's Razor are vulnerable to a Denial of Service attack when handling certain malformed messages.

Affected Packages

mail-filter/spamassassin on all architectures
Affected versions < 3.0.4
Unaffected versions >= 3.0.4, < 3.0.1
mail-filter/razor on all architectures
Affected versions < 2.74
Unaffected versions >= 2.74

Background

SpamAssassin is an extensible email filter which is used to identify junk email. Vipul's Razor is a client for a distributed, collaborative spam detection and filtering network.

Description

SpamAssassin and Vipul's Razor contain a Denial of Service vulnerability when handling special misformatted long message headers.

Impact

By sending a specially crafted message an attacker could cause a Denial of Service attack against the SpamAssassin/Vipul's Razor server.

Workaround

There is no known workaround at this time.

Resolution

All SpamAssassin users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-filter/spamassassin-3.0.4"

All Vipul's Razor users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-filter/razor-2.74"

References

Release Date
June 21, 2005

Latest Revision
May 22, 2006: 03

Severity
normal

Exploitable
remote

Bugzilla entries