WordPress contains PHP script injection, cross-site scripting and path disclosure vulnerabilities.
|Package||www-apps/wordpress on all architectures|
|Affected versions||< 188.8.131.52|
|Unaffected versions||>= 184.108.40.206|
WordPress is a PHP and MySQL based content management and publishing system.
James Bercegay of the GulfTech Security Research Team discovered that WordPress insufficiently checks data passed to the XML-RPC server. He also discovered that WordPress has several cross-site scripting and full path disclosure vulnerabilities.
An attacker could use the PHP script injection vulnerabilities to execute arbitrary PHP script commands. Furthermore the cross-site scripting vulnerabilities could be exploited to execute arbitrary script code in a user's browser session in context of a vulnerable site.
There are no known workarounds at this time.
All WordPress users should upgrade to the latest available version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-apps/wordpress-220.127.116.11"
July 04, 2005
July 04, 2005: 01