phpBB: Arbitrary command execution — GLSA 200507-03

A vulnerability in phpBB allows a remote attacker to execute arbitrary commands with the rights of the web server.

Affected Packages

www-apps/phpBB on all architectures
Affected versions < 2.0.16
Unaffected versions >= 2.0.16

Background

phpBB is an Open Source bulletin board package.

Description

Ron van Daal discovered that phpBB contains a vulnerability in the highlighting code.

Impact

Successful exploitation would grant an attacker unrestricted access to the PHP exec() or system() functions, allowing the execution of arbitrary commands with the rights of the web server.

Workaround

Please follow the instructions given in the phpBB announcement.

Resolution

The phpBB package is no longer supported by Gentoo Linux and has been masked in the Portage repository, no further announcements will be issued regarding phpBB updates. Users who wish to continue using phpBB are advised to monitor and refer to www.phpbb.com for more information.

To continue using the Gentoo-provided phpBB package, please refer to the Portage documentation on unmasking packages and upgrade to 2.0.16.

References

Release Date
July 04, 2005

Latest Revision
September 03, 2005: 03

Severity
high

Exploitable
remote

Bugzilla entries