phpWebSite: Multiple vulnerabilities — GLSA 200507-07

phpWebSite is vulnerable to the remote execution of arbitrary PHP script code and to other, yet undisclosed, vulnerabilities.

Affected Packages

www-apps/phpwebsite on all architectures
Affected versions < 0.10.1-r1
Unaffected versions >= 0.10.1-r1

Background

phpWebSite is a content management system written in PHP.

Description

phpWebSite fails to sanitize input sent to the XML-RPC server using the "POST" method. Other unspecified vulnerabilities have been discovered by Diabolic Crab of Hackers Center.

Impact

A remote attacker could exploit the XML-RPC vulnerability to execute arbitrary PHP script code by sending specially crafted XML data to phpWebSite. The undisclosed vulnerabilities do have an unknown impact.

Workaround

There is no known workaround at this time.

Resolution

All phpWebSite users should upgrade to the latest available version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-app/phpwebsite-0.10.1-r1"

References

Release Date
July 10, 2005

Latest Revision
July 10, 2005: 01

Severity
high

Exploitable
remote

Bugzilla entries