Adobe Acrobat Reader: Buffer overflow vulnerability — GLSA 200507-09

Adobe Acrobat Reader is vulnerable to a buffer overflow that could lead to remote execution of arbitrary code.

Affected Packages

app-text/acroread on all architectures
Affected versions <= 5.10
Unaffected versions >= 7.0

Background

Adobe Acrobat Reader is a utility used to view PDF files.

Description

A buffer overflow has been discovered in the UnixAppOpenFilePerform() function, which is called when Adobe Acrobat Reader tries to open a file with the "\Filespec" tag.

Impact

By enticing a user to open a specially crafted PDF document, a remote attacker could exploit this vulnerability to execute arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

Since Adobe will most likely not update the 5.0 series of Adobe Acrobat Reader for Linux, all users should upgrade to the latest available version of the 7.0 series:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/acroread-7.0"

References

Release Date
July 11, 2005

Latest Revision
July 11, 2005: 01

Severity
normal

Exploitable
remote

Bugzilla entries