GNU Gadu, CenterICQ, Kadu, EKG, libgadu: Remote code execution in Gadu library — GLSA 200507-26

GNU Gadu, CenterICQ, Kadu, EKG and libgadu are vulnerable to an integer overflow which could potentially lead to the execution of arbitrary code or a Denial of Service.

Affected Packages

net-im/gnugadu on all architectures
Affected versions < 2.2.6-r1
Unaffected versions >= 2.2.6-r1
net-im/centericq on all architectures
Affected versions < 4.20.0-r3
Unaffected versions >= 4.20.0-r3
net-im/kadu on all architectures
Affected versions < 0.4.1
Unaffected versions >= 0.4.1
net-im/ekg on all architectures
Affected versions < 1.6_rc3
Unaffected versions >= 1.6_rc3
net-libs/libgadu on all architectures
Affected versions < 1.7.0_pre20050719
Unaffected versions >= 1.7.0_pre20050719

Background

GNU Gadu, CenterICQ, Kadu and EKG are instant messaging applications created to support Gadu Gadu instant messaging protocol. libgadu is a library that implements the client side of the Gadu-Gadu protocol.

Description

GNU Gadu, CenterICQ, Kadu, EKG and libgadu are vulnerable to an integer overflow.

Impact

A remote attacker could exploit the integer overflow to execute arbitrary code or cause a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All GNU Gadu users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-im/gnugadu-2.2.6-r1"

All Kadu users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-im/kadu-0.4.1"

All EKG users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-im/ekg-1.6_rc3"

All libgadu users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/libgadu-20050719"

All CenterICQ users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-im/centericq-4.20.0-r3"

CenterICQ is no longer distributed with Gadu Gadu support, affected users are encouraged to migrate to an alternative package.

References

Release Date
July 27, 2005

Latest Revision
February 26, 2007: 02

Severity
high

Exploitable
remote

Bugzilla entries