pstotext: Remote execution of arbitrary code — GLSA 200507-29

pstotext contains a vulnerability which can potentially result in the execution of arbitrary code.

Affected Packages

app-text/pstotext on all architectures
Affected versions < 1.8g-r1
Unaffected versions >= 1.8g-r1

Background

pstotext is a program that works with GhostScript to extract plain text from PostScript and PDF files.

Description

Max Vozeler reported that pstotext calls the GhostScript interpreter on untrusted PostScript files without specifying the -dSAFER option.

Impact

An attacker could craft a malicious PostScript file and entice a user to run pstotext on it, resulting in the execution of arbitrary commands with the permissions of the user running pstotext.

Workaround

There is no known workaround at this time.

Resolution

All pstotext users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/pstotext-1.8g-r1"

References

Release Date
July 31, 2005

Latest Revision
August 11, 2005: 02

Severity
normal

Exploitable
remote

Bugzilla entries